Symptom
When an email notification is triggered for approval/rejection of Purge request, the email notification received by the end user contains strange characters like diamond with a question mark etc.
Environment
SAP SuccessFactors HCM Core 2411
Reproducing the Issue
- Access the instance
- Go to Admin Center > Data Retention Management > Create New Purge Request > Under "Select a purge request type", choose "DRTM Master Data Purge".
- Use subject criteria to define the users whose data you want to purge:
- Choose from the available options
Select one user. Use this option to purge data for an individual user.
Upload a user list (by User ID or Assignment ID). Use this option to purge data for multiple users, based on your own criteria. Use the downloadable CSV example as a template - Add one or more approvers. Use the Add approvers search box to add the first approver. To add another, select Add another approver.
- Launch immediately
- Proxy as the approver
- Navigate to Purge Request Monitor
- Action the Request (Approve or Reject)
- The email received by the approver post approval/rejection contains strange characters.
Cause
The issue is caused due to the user's Microsoft outlook settings.
Resolution
Check the Language settings in Outlook or reach out to Microsoft support for further assistance on resolving the issue.
The below link is subject to change per Microsoft. Any assistance with outlook settings should be worked on with Microsoft Support. SAP Support cannot provide assistance in Microsoft Outlook settings/configurations.
Strange characters in Outlook email text - Outlook | Microsoft Learn
Keywords
Strange characters, Purge notification, Email notification, LOD-SF-PLT, Master Data Purge, Purge approval, SuccessFactors, Platform, DRTM, Data Retention Management , KBA , LOD-SF-PLT-DRM , Data Retention Management , LOD-SF-PLT-NOT , Email Notifications , Problem