Symptom
When creating or editing an In-House Bank Account in app Manage In-House Bank Accounts, error 'A requested database entry was not found in 'BNKA'' occurs.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental"
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to app Manage In-House Bank Accounts.
- Create or Edit an In-House Bank Account.
- Error 'A requested database entry was not found in 'BNKA'' occurs.
Cause
Bank Key stands for technical identifier and Bank Number is the business identifier. The Bank Key in the configuration step Define Bank Areas for Account Management (SSCUI 105773) assigned to the Bank Area of the In-House Bank Account is not equal to the Bank Number maintained in app Manage Banks – Master Data.
Resolution
The Bank Key in Define Bank Areas for Account Management (SSCUI 105773) assigned to the Bank Area of the In-House Bank Account should be same as the respective Bank Number maintained in app Manage Banks – Master Data.
- Bank Number in app Manage Banks – Master Data.
- Bank Key in configuration step Define Bank Areas for Account Management (SSCUI 105773).
See Also
Keywords
Manage In-House Bank Accounts, BNKA, FIN-FSCM-PF, In-House Bank Account, Bank Key, Bank Number, Define Bank Areas for Account Management, 105773, Bank Area, Manage Banks – Master Data , KBA , FIN-FSCM-PF , Payment Factory , Problem