SAP Knowledge Base Article - Public

3585925 - Error "Units of different dimensions cannot be converted" during Service Order baseline

Symptom

When creating a Service Order with a service item (item category SVP1) that uses a tangible unit of measure (e.g. PC, EA, M, KG), the baseline calculation cannot be completed successfully due to error: "Units of different dimensions cannot be converted".

Environment

SAP S/4HANA Cloud Public Edition

Cause

The item category SVP1 (Service Item) treats the item as "the time required to provide a service", so the system would use for calculation the item net price multiplied by the planned or agreed working hours.

It's not possible to convert tangible UoMs, e.g. PC, M, KG, to non-tangible UoMs like Time.

Resolution

The service material should be adjusted:

  • In the material master, maintain the item category group as SRVM.
  • In the service order, maintain the item category as SVS1.

For the item category 'Service Part' (SVS1), the system uses for calculation the item net price multiplied by the quantity, so there's no conversion involved.

Note that if the service order item is already in status 'Released', it's not possible to change the item category anymore. It's necessary to create a new order.

See Also

Service Orders - Item Categories | SAP Help Portal

3563217 - Service documents : warning message "Units of different dimensions cannot be converted" (BM311) - onPrem

Keywords

unit of measurement, SVP1, SVO, SVS1, SRVM, service order, baseline calculation, planned costs and revenue, work hours, conversion , KBA , CRM-S4-SRV-SVO-2CL , S4CRM: Service Order (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions