Symptom
- When trying to delete knowledge base article, error is thrown: product is in use
- When checking usage, nothing is present.
Environment
SAP SALES CLOUD CPQ connected with S/4HANA
Reproducing the Issue
- In Setup, open Knowledge Base Diagnostics
- In last tab, open Delete Invalid Knowledge Bases
- Try to delete one KB, error will be thrown
- On Actions, nothing will be visible in the usage.
Cause
Product is being used by someone in favorites, which prevents deletion.
Favorites is shown only locally, not being possible to identify and delete them through an admin.
Resolution
Deletion should also delete product from favorites, this will be corrected in an upcoming release.
See Also
Keywords
CPQ, CPS, S4 system copy, KB inconsistency, Effective Today flag, product addition, quote, error, synchronization. , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Known Error
Product
SAP CPQ all versions