SAP Knowledge Base Article - Public

3586443 - After Business Partner Merge in C4C the Old Account Is Not Updated in the ERP System

Symptom

You have successfully merged Business Partner in C4C. However, these changes have not been updated in the ERP System and the Account was not set to obsolete.

Environment

  • SAP Cloud for Customer
  • SAP ERP

Reproducing the Issue

  1. Go to the Data Cleansing Work center.
  2. Click on New.
  3. Enter details.
  4. Save and open.
  5. Maintain preferences in the Attribute Selection and save.
  6. Initiate Merge.

Cause

This is the expected system behavior because this is an integration between C4C and ERP. Activating merge leads to inconsistencies if C4C system is integrated with another system (ERP) which does not support account merge.

Resolution

Switch-off the Account merge option in C4C in order to avoid misuse:

  1. Go to the Business Configuration work center.
  2. Go to Implementation Projects view.
  3. Select Edit Project Scope button.
  4. Go to Questions section.
  5. Expand General Business Data.
  6. Business Partners.
  7. Handling of Business Partners.
  8. De-select the question "Do you want to enable accounts merge?".
  9. Complete the scoping by selecting Confirm and Finish.

Keywords

C4C, Merge, Obsolete, ERP , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To

Product

SAP Cloud for Customer core applications 2502