SAP Knowledge Base Article - Public

3586523 - Error Message Referenced Address UUID ABC of Customer 123 Is Not Known to the System When Replicating Data via BusinessPartnerRelationshipReplicationIn to C4C

Symptom

You are using BusinessPartnerRelationshipReplicationIn to replicate Business Partner relationships to C4C and you are facing the error "Referenced Address UUID ABC of Customer 123 Is Not Known to the System" (where ABC and 123 mean generic IDs) on the web service message monitoring.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Go to the General Setting work center view.
  3. Open the Web Service Message Monitoring under System Administration.
  4. Select query All.
  5. Search for message ID 123456 (where 123456 means a generic ID).

Error: "Referenced Address UUID ABC of Customer 123 Is Not Known to the System".

Cause

The incoming payload for Service Interface BusinessPartnerRelationshipReplicationIn looks like:
 
    <BusinessPartnerRelationship actionCode="04" employeeResponsibleListCompleteTransmissionIndicator="false">
      <BusinessPartnerInternalID>123</BusinessPartnerInternalID>
      <RelationshipBusinessPartnerInternalID>xxxxx</RelationshipBusinessPartnerInternalID>
      <SenderSequenceNumberValue>xxxxx</SenderSequenceNumberValue>
      <RoleCode>BUR001</RoleCode>
...
      <ContactPerson actionCode="04" workplaceAddressListCompleteTransmissionIndicator="true">
        <BusinessPartnerFunctionTypeCode>xxxxx</BusinessPartnerFunctionTypeCode>

        <WorkplaceAddressInformation actionCode="04">
          <AddressUUID>ABC</AddressUUID>
          <DefaultIndicator>true</DefaultIndicator>
...
 
        <CustomerContactPerson>
          <InternalID>987</InternalID> (where 987 means a generic ID)
        </CustomerContactPerson>
 
 
When checking the C4C system, the Contact 987 is no available in C4C.
This error will come when there is a new address set updated in your external system for Business Partner and the same is not available in C4C. Therefore the message is failing as contact person in the payload is not in Cloud for Customer.

Resolution

You need to load the Account with its Address firstly. So that, the address UUIDs are created in C4C. Then when you process the account - contact relationship message C4C system can identify the UUID of workplace address. 

So, summing up, please do the following:

  • Replicate the Account C4C ID with AddressUUID ABC.
  • After that, replicate the Contact ID 987 to C4C.
  • Then, you can re-process the Relationship of both master data.

Keywords

C4C, Cloud for Customer, AddressUUID, Referenced Address UUID, Referenced, Address UUID, UUID, BusinessPartnerRelationshipReplicationIn, Contact. , KBA , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , How To

Product

SAP Cloud for Customer core applications all versions