Symptom
Outlook keeps sending meeting confirmation mail to the user for a visit (The visit here could be one - not yet started, already started)
Environment
SAP Cloud For Customer
Outlook Integration
Reproducing the Issue
- Create a visit.
- Make any changes to key fields (such as subject, start time, end time, or location).
- Notice that a meeting confirmation mail from outlook is triggered to the user.
Cause
In case of updating the field Location for example -
If the location is automatically updated in C4C during the initial synchronization (or any subsequent one), the location will be overwritten in Outlook during the next update from C4C, and attendees will receive an updated invitation.
However, if changes are made to an event in the past (i.e., the event's start time has already passed), such updates will not trigger an invitation to be sent. By design, the product only sends invitations in such scenarios for meetings that have not yet started.
C4C typically auto-populates the **Location** field once the appointment is linked to an account. This is standard CRM behavior. If the **Location** field in C4C differs from the one in Outlook, during the next sync session, the location in Outlook will be updated (either added or overwritten with the new value). For events that have not yet started, this update will trigger a new invitation to be sent to attendees.
Resolution
-
For events that have not yet started:
Changes to key fields (such as subject, start time, end time, or location) will trigger the system to send updated invitations to all attendees to notify them of the changes. -
For events that have already started or ended:
Changes to key fields will result in only a technical update within the system without sending new invitations to attendees."
This is the expected system behavior.
Keywords
Meeting confirmation mail, visit, updating location, Outlook confirmation , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , Problem