Symptom
When opening a timesheet you receive the following error
Your timesheet entries were not successfully imported. Please contact your administrator.
Reason: An object (EmployeeTimeSheet) with this external code (***) was update in the meantime, please refresh
Environment
- Employee Central Core
- Time Tracking
Reproducing the Issue
- Open a timesheet for an affected employee
- After loading or when making an entry, the error is received
Cause
This error can be caused by an update to times being run while there already is a record actively being imported.
This is causing the conflict. As the user would not have visibility on this, it would be very difficult to avoid or predict.
Resolving these alerts will have to be done manually for the time being.
We are working on an alert improvement to avoid this in future releases but
at this point in time, we do not have a timeline for this enhancement.
Resolution
- Verify that current timesheet data is correct
- Check manage data > external time data to ensure no record is in error status for this employee
- Reprocess alert in time alert interface
- After verifying data is correct but error persists, go to Time Management Alert in manage data and open the record for this timesheet
- Delete the alert
Keywords
import conflict , KBA , LOD-SF-EC-TMS , Time Sheet , Problem