SAP Knowledge Base Article - Public

3587060 - Fields are not editable in SAP Sales Cloud Mobile App

Symptom

Some fields are not editable when using the SAP Sales Cloud Mobile App.

Environment

SAP Sales Cloud and SAP Service Cloud Version 2

Reproducing the Issue

  1. Open SAP Sales cloud app and login.
  2. Go to Menu and open affected entity.
  3. Open a record.
  4. Click on the >> button to see general information.
  5. Notice the field X is available.
  6. Click on the pencil button to edit.
  7. The X field is not shown for edition.

Cause

In order to edit some fields in mobile it's necessary to to add fields Technical ID in the Mobile Admin settings.

Resolution

  1. Go to the Web UI.
  2. Login as Admin.
  3. Go to Settings.
  4. Enter Mobile Administration view. 
  5. Open the view for relevant entity.
  6. Add fields Technical ID, for example 'Sales Unit Details // Technical ID'.

Also please make sure the updatable property is set as true in Extensibility Admin (Field attributes).

Keywords

Mobile, Edit, Read-Only, Editable , KBA , CEC-CRM-MOB-ADM , Mobile Administration for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0