Symptom
Some fields are not editable when using the SAP Sales Cloud Mobile App.
Environment
SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
- Open SAP Sales cloud app and login.
- Go to Menu and open affected entity.
- Open a record.
- Click on the >> button to see general information.
- Notice the field X is available.
- Click on the pencil button to edit.
- The X field is not shown for edition.
Cause
In order to edit some fields in mobile it's necessary to to add fields Technical ID in the Mobile Admin settings.
Resolution
- Go to the Web UI.
- Login as Admin.
- Go to Settings.
- Enter Mobile Administration view.
- Open the view for relevant entity.
- Add fields Technical ID, for example 'Sales Unit Details // Technical ID'.
Also please make sure the updatable property is set as true in Extensibility Admin (Field attributes).
Keywords
Mobile, Edit, Read-Only, Editable , KBA , CEC-CRM-MOB-ADM , Mobile Administration for SAP Sales/Service Cloud , How To
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0