SAP Knowledge Base Article - Public

3587147 - New Hire Not Showing in Onboarding After Successful Initiation from RCM, with BPE error: 'hrisSaveStatusVO' is null

Symptom

  • A new hire was initiated from recruiting to onboarding, but is not showing in the onboarding process.
  • An exception message is displayed in BPE: Manage process tasks: "Cannot invoke 'com.successfactors.hris.api.bean.vo.IHrisSaveStatusVO.addHrisSaveStatus(String, String)' because 'hrisSaveStatusVO' is null".
  • An application error occurs when attempting to trigger or restart the task.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Initiate onboarding from RCM.
  2. Check for the new hire in the onboarding process.
  3. Observe that the new hire is not present in the onboarding process.
  4. An exception message is displayed in BPE: Manage process tasks: "Cannot invoke 'com.successfactors.hris.api.bean.vo.IHrisSaveStatusVO.addHrisSaveStatus(String, String)' because 'hrisSaveStatusVO' is null".
  5. An application error occurs when attempting to trigger or restart the task.

Cause

The issue is caused by invalid HRIS sync job owner. Job owner is inactive.

Resolution

  1. Identify the invalid HRIS sync job owner.
  2. Replace the job owner of HRIS sync job to a valid user.
  3. Restart the stuck task from BPE Manage process tasks.

See Also

Keywords

Onboarding, New Hire, HRIS Sync Job, Invalid Owner, BPE Manage Process Tasks, SAP SuccessFactors Onboarding. , KBA , LOD-SF-OBX-RCM , Initiate onboarding from RCM , Problem

Product

SAP SuccessFactors Onboarding all versions