Symptom
The code group codes are not visible for a specific user in the "Record Inspection Results" app but for other user, it's visible.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Navigate to Manage inspection lots.
- Provide Inspection lot origin.
- Select an inspection lot without result recording.
- Click on the "Record Results" button and be directed to the "Record Inspection Results" app.
- Click Edit.
- Select a qualitative MIC.
- Select the Code Group - Code drop down.
Cause
For visible user, the Access Categories for role that contains business category 'SAP_QM_BC_RESULT_RECG_PC' is unrestricted. It means there are no restrictions for this role and it's able to see the code group value help. However, for user who is not able to see the code group codes, the Access Categories for role are restricted, which means once some fields have been maintained, it's suggested to set all other fields "fields setting" as "Unrestricted Access" manually, otherwise it will be set as Restricted by default.
Resolution
- Identify the role that maintains the Fiori app business category.
- Check restriction type, see if in "Selected Set", the "read, value help" and "value help" field are restricted.
- Set fields as "unrestricted" in case similar situation occurs.
Keywords
Fiori app, Record Inspection Results, Code Group Codes, Invisible, Quality Inspection, User, Restricted Access, Unrestricted Access, Field Settings, Role , KBA , QM-FIO-IM-RR-2CL , Quality Inspection Fiori appl. Results Record. (Public Cld) , Problem