SAP Knowledge Base Article - Public

3587754 - No edit access error while attaching a document to a Background OData entity.

Symptom

  • An issue arises when attempting to attach a document to a Background OData entity.
  • The error message received is: "Employee [API Username] has no Edit access to record 1".

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental. 

Environment

  • SuccessFactors BizX
  • OData API Framework

Cause

The error occurred because the API user had both admin and user permissions, and the admin permission was only used to query the data. If the API user have both the admin and user permissions, the admin permission applies. 

Resolution

  1. Identify the user permissions for API user.
  2. Remove the admin permission (Administrator Permissions >> Manage User >> Export Extended User Information) to resolve the error.

See Also

Background entities permissions

Keywords

SAP SuccessFactors, CPI Integration, ODATA API, MDF custom object API, Document Attachment, Error Message, User Permissions, Admin Permission, Resolution, Background OData entity , KBA , LOD-SF-INT-ODATA , OData API Framework , Problem

Product

SAP SuccessFactors HCM Suite 2405