SAP Knowledge Base Article - Public

3587840 - General tab is not visible after adding new tab in product layout

Symptom

  • An issue arises in the SAP CPQ product layout when adding a new tab to the product.
  • After adding the new tab, the previously existing "General" tab is not displayed despite the visibility condition for both tabs being set to "Always displayed".

Environment

SAP Sales Cloud CPQ

Reproducing the Issue

  1. Go to setup
  2. Edit a product
  3. Go to the layout tab.
  4. Click on Add/Edit.
  5. Add a new tab and set to always visible.
  6. Exit setup.
  7. Create a new quote and add the product.
  8. Observe that the "General" tab does not appear, only the new tab is visible.

Cause

  • If it's a CPQ product, not synced from back-office, then this is an expected behavior where the "General" tab becomes invisible when a new tab is added to the product layout in the SAP CPQ setup.
  • This occurs despite the visibility condition for both tabs being set to "Always displayed".

Resolution

  • To show general tab in configurator, a setting in the backend should be modified.
  • To resolve this issue please contact CPQ Support team for modifying a setting in backend.

See Also

Keywords

SAP CPQ, Product Layout, Tab Visibility, Hidden Product Attributes, General Tab, Always Displayed, Backend Changes, Hidden Parameter. , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem

Product

SAP CPQ all versions