Symptom
- An error message is encountered while posting goods issue in outbound delivery with serial numbers.
- The error message states: "A critical error occurred. Contact your system administrator."
- The delivery contains a single item with huge amount of serial numbers, for example, 50000 serial numbers.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Enter app Manage Outbound deliveries or VL01N.
- Press the button "Post GI" or "Post Goods Issue".
- After a while, the error "A critical error occurred. Contact your system administrator." raised.
Cause
The issue is caused by the presence of huge amount serial numbers in the delivery, which results in a TIMEOUT error while posting goods issue at the frontend.
Resolution
Schedule background job to post goods issue for outbound delivery, detailed steps can be referred as below:
- Enter app Schedule Goods Issue for Deliveries.
- Create a new job using job template 'Schedule Goods Issue for Deliveries'.
- Maintain the filter values, e.g., Delivery number. Note that the pre-requisites for the job is Outbound Delivery must have Picking status 'Not relevant' or 'Completed'.
- Schedule the job and wait for the job to finish.
Keywords
Outbound Delivery, Post Goods Issue, Serial Numbers, TIMEOUT, Background Job. , KBA , LE-SHP-FIO-2CL , Fiori Apps - Delivery Documents (Public Cloud) , Problem
Product
SAP S/4HANA Cloud Public Edition all versions