SAP Knowledge Base Article - Public

3587858 - Model Based On Product Recommendation Scenario is Failing

Symptom

You have created a ML model which is based on Product Recommendation scenario and is failing.

Environment

  • SAP Sales Cloud and SAP Service Cloud Version 2

Reproducing the Issue

  1. Log in to the tenant.
  2. Navigate to Settings.
  3. Search for Intelligent Service. 
  4. Locate the Product Recommendation Scenario and check the status of the model created in it. 
  5. Notice that the status of the model is marked as "Failed." 

Cause

  • Model training requires one year's worth of opportunity data. 
  • Opportunities must be in the Won state and include line-item products.

Resolution

  1. Ensure that products are linked to the opportunities and contain qualified data. 
  2. Verify that the prerequisites mentioned in the Help Center Document are met. 
  3. Confirm that you have a set of product combinations that can be used for recommendations. 
  4. For example, if you used Product A and Product B in an opportunity, and you create another opportunity with Product A, the system should display an icon suggesting the inclusion of Product B. 
  5. The ML model is designed to provide recommendations for quick upselling offers within the opportunity.

See Also

Help Document: Product Recommendation

Keywords

Machine Learning, Product Recommendation, Fail, Intelligent Services, Model Training, Opportunity, Dataset, Sales, Service , KBA , CEC-CRM-ML , Machine Learning for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions