Symptom
You have created a ML model which is based on Product Recommendation scenario and is failing.
Environment
- SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
- Log in to the tenant.
- Navigate to Settings.
- Search for Intelligent Service.
- Locate the Product Recommendation Scenario and check the status of the model created in it.
- Notice that the status of the model is marked as "Failed."
Cause
- Model training requires one year's worth of opportunity data.
- Opportunities must be in the Won state and include line-item products.
Resolution
- Ensure that products are linked to the opportunities and contain qualified data.
- Verify that the prerequisites mentioned in the Help Center Document are met.
- Confirm that you have a set of product combinations that can be used for recommendations.
- For example, if you used Product A and Product B in an opportunity, and you create another opportunity with Product A, the system should display an icon suggesting the inclusion of Product B.
- The ML model is designed to provide recommendations for quick upselling offers within the opportunity.
See Also
Help Document: Product Recommendation
Keywords
Machine Learning, Product Recommendation, Fail, Intelligent Services, Model Training, Opportunity, Dataset, Sales, Service , KBA , CEC-CRM-ML , Machine Learning for SAP Sales/Service Cloud , How To
Product
SAP Sales Cloud and SAP Service Cloud Version 2 all versions
SAP Knowledge Base Article - Public