Symptom
An error message appears when attempting to send a SEPA mandate via the ODATA API_APAR_SEPA_MANDATE_SRV.
The error message states: "Customer & does not have bank details with IBAN &".
Environment
SAP S/4HANA Public Cloud Edition
Reproducing the Issue
Customer and IBAN are correctly maintained in BP master data. Send SEPA Mandate via API_APAR_SEPA_MANDATE_SRV.
Here is an example of the Payload file where:
- Customer number is entered in <Sender>
- IBAN is entered in <SenderIBAN>
<SEPAMandateSet>
<SEPAMandateType>
<Creditor>xxxxxxxxxxxxxxxxxx</Creditor>
<SEPAMandate>nnn-nnnn</SEPAMandate>
<SEPAMandateApplication>F</SEPAMandateApplication>
<SEPAPaymentType>N</SEPAPaymentType>
<SenderType>XXXnnnn</SenderType>
<Sender>123456789</Sender>
<SenderCountry>XY</SenderCountry>
<SenderIBAN>XXnnnnnnnnnnnnnnnnnnnn</SenderIBAN>
<SenderBankSWIFTCode>XXXXXXXXXXX</SenderBankSWIFTCode>
<RecipientType>XXXnnnn</RecipientType>
<Recipient>nnnn</Recipient>
<RecipientCountry>XY</RecipientCountry>
<ValidityStartDate>YYYY-MM-DD</ValidityStartDate>
<SEPASignatureCityName>Somewhere</SEPASignatureCityName>
<SEPASignatureDate>YYYY-MM-DD</SEPASignatureDate>
<SEPAMandateStatus>1</SEPAMandateStatus>
</SEPAMandateType>
</SEPAMandateSet>
Cause
The issue arises due to incomplete Customer number (9 digits or less).
Resolution
<Sender> is set up for 10 digits. If Customer number has 9 digits or less, fill it to 10 digits with leading zero.
Keywords
SAP S/4HANA Cloud Public Edition, SEPA Mandate, ODATA API, Error, Customer, IBAN, Bank Details, Master Data, API_APAR_SEPA_MANDATE_SRV, FSEPA_M3_PC, SEPA055, SEPA 055 , KBA , CA-BK-SEP-2CL , SEPA Mandates: Public Cloud , Problem