Symptom
The Identify Customer and Contact button is not visible on Leads for certain users
Environment
SAP Sales Cloud Version 2
Cause
The user in question has restricted read and write access for Accounts and Contacts via their business role. They are also not a part of the Lead Sales Team or the Sales Unit assigned to the Lead. Thus, their access restrictions prevent them from creating an Account.
Resolution
This is the expected system behaviour. The user in question will need to either have unrestricted read and write access for Accounts and Contacts, or be added to the Lead Sales Team/relevant Sales Unit before they can create an Account or Contact from the relevant Lead.
Keywords
lead, identify account and contact , KBA , CEC-CRM-LEA , Lead for SAP Sales/Service Cloud , Problem