SAP Knowledge Base Article - Public

3588141 - Incorrect Form Template Selected for Customer Invoices Output in Intercompany Scenarios

Symptom

The system is not selecting the correct form template for e-mail outputs for customer invoices in intercompany scenarios.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Customer Invoicing Work Center.
  2. Go to Invoice Documents View.
  3. In the dropdown, select All Invoice Documents.
  4. Search for the Customer Invoice ABC (where ABC refers to the document ID).
  5. Select the Customer Invoice ABC.
  6. Click on Edit.
  7. Go to the Output History tab.

The Customer Invoice template is defined differently from the form template maintained in the rules of the Form Template Selection View.

Cause

The account defined in the Customer Invoice has the output configurations for Internal EDX output selected and with a template maintained.

However, the E-mail output option is also defined in the account and with the Template field left blank. 

This can be verified by following the below steps:

  1. Navigate to the Account Management Work Center.
  2. Go to the Accounts View.
  3. Search for the account XYZ (where XYZ refers to the account ID) in the search field.
  4. Open the account XYZ.
  5. Select View All.
  6. Go to the Communication tab and then to the Collaboration sub-tab.
  7. Select the Business Document Customer Invoice/Credit Memo.

The Internal EDX option is selected with a form template maintained and the E-mail output option is selected with no form template maintained.

In this case, the system uses the same form template maintained in the Internal EDX output for E-mail output in the Customer Invoice document.

Resolution

This is a standard system behavior.

To maintain a different form template for the E-mail output of the Customer Invoice document, a specific template can be maintained in the account for the E-mail Output.

To perform this modification, follow the below steps:

  1. Navigate to the Account Management Work Center.
  2. Go to the Accounts View.
  3. Enter XYZ in the search field.
  4. Open Account XYZ.
  5. Select View All.
  6. Go to the Communication tab and then to the Collaboration sub-tab.
  7. Select the Business Document Customer Invoice/Credit Memo.
  8. In the Output definition of the account, ensure that the E-mail output option has the form template field filled.

The form template for the customer invoice document will now be chosen based on the template maintained in the E-mail output definition of the account.

See Also

Keywords

Intercompany, Invoice, Form, Incorrect, Selection, Output, Template, Account, Communication, Collaboration, Business Document, Customer Invoice, Credit Memo. , KBA , AP-RC-FF , Forms Flexibility , How To

Product

SAP Business ByDesign all versions