Symptom
- An application error occurs when trying to purge inactive users via DRTM Master Purge
- The application error ID might be accompanied by error: Person data purge failed. Please check server log or create a ticket
- Purge immediately fails with Reviewing... status
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Perform a Master Data Purge as per 2545988 - How To Purge or Delete Users In SuccessFactors
- Observe that there is an application error or the purge fails immediately
Cause
The issue was caused by error "Invalid service, please check if DMS has been configured properly, status=null
- Go To Admin Center -> Configure Document Management
- Check if they configured DMS properly.
Resolution
-
Employee Central is required for enabling the integration of either Core or Extended ECM with SAP SuccessFactors.
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Enable OpenText Integration and Enable the Attachment Manager must be selected in Provisioning.
Note:
-
If customer is not using open text then disable switch from provisioning with customer approval and have the customer test again.
-
This should only be enabled IF the customer is using 3rd party storage solutions.
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If customer is using open text then provide a screenshot of the configuration from admin center > configure document management
Customer must provide a written approval for above task (Create job: Workflow Action Reminder)
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Access the customer's Provisioning >> Company Settings.
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Disable the 'Enable OpenText Integration' switch.
-
Save
FAQ - Additional Information
Q) Where can I get information on this from the Guide?
A) Guide: Integrating SAP SuccessFactors with OpenText
Chapter: Setting Up Integration with OpenText
See Also
- 2545988 - How to Purge/Delete users in SuccessFactors
- 3375924 - How To check User Status Via Data inspector
- 3016149 - Error in getting document from DMS: Invalid service, please check if DMS has been configured properly - Onboarding
- 2615360 - Data Protection and Privacy - Data Retention Time Management (DRTM) - Master Data Purge for Inactive Users
- 2618726 - Syncing the country/region of Company between Employee Central and the SuccessFactors Platform
- 2589774 - How to clear Metadata Framework (MDF) Cache
- 2511979 - Employee Central: How do I Terminate employees via Import?
- 2749427 - Unable To Permanently Purge user after a Soft Purge
- 2657326 - Data Retention Time Management: Person and Employment Purge Object FAQ
- 2584658 - How to Check if a User is an EC User using the Integration Center
- 2324204 - How to retrieve inactive employees via Integration Center?
- 2461415 - Delete Concurrent Employment
- 2392094 - Re-activate a Purged User Via employee Import Feature
- 2596758 - Soft Purged Users Report
Keywords
purge , Enable Open Text Integration, Enable the Attachment Manager, Error :Caused by: com.successfactors.attachment.util.AttachmentException: Invalid service, please check if DMS has been configured properly, status=null, Configure Document Management enable opentext integration, Person data purge failed. Please check server log or create a ticket, Configure Document Management, Exception during validating the SF OAuth Token via HTTP, INC16162607, successfactors, SFSF. , KBA , LOD-SF-PLT-DRM , Data Retention Management , Problem
SAP Knowledge Base Article - Public