Symptom
When completing the I9 Section 3 task, the dropdowns do not display any values after selecting "Yes" for List A.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
1. Proxy the responsible user.
2. Open Section 3 of the I9 for the candidate.
3. Select "Yes" for List A.
4. The dropdown does not show any available values.
Cause
The candidate does not have a Citizenship Type assigned.
Resolution
- Go to Manage Data.
- Search for I9 User Data > User ID of the candidate
- Maintain the Citizenship Type of the candidate then save.
- Go back to I9 Section 3 then you will be able to load the dropdown lists for List A, B, and C.
See Also
3439129 - I9 Reverification not triggered when job is configured - Onboarding
Keywords
I9, Section 3, dropdown, blank, CitizenShip, CitizenShip Type, List A, I9 User Data, OBX, Onboarding , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Problem
Product
SAP SuccessFactors Onboarding all versions