SAP Knowledge Base Article - Public

3588987 - Crystal report fails to View or Refresh after changing ODBC

Symptom

  • Crystal report fails with below after changing ODBC connection while viewing or refreshing:

"The viewer could not process an event. Failed to open the connection.<Report Name>.rpt [] ---- Error code:0 [CRWEB00000119] "

  • ODBC driver used is 32/64 bit as System DSN Crystal Report Database.
  • The DSN works in CR designer but fails in CMC/BILP even after publishing.

Environment

  • SAP BusinessObjects Business Intelligence Platform (BI) 4.x
  • Windows Server

Reproducing the Issue

  1. Login to Central Management Console or BI LaunchPad.
  2. Navigate to Crystal Report with new ODBC datasource.
  3. Try to view or refresh.

Cause

  •  There is a corrupted ODBC connection in the Crystal Reports 

Resolution

  • Change the corrupted connection maintained in the Crystal Reports.
  • Update the new db user in the CMC crystal report "Database configuration" with the correct ID/Password.

Keywords

4.x, BIP, ODBC, CR, crystal reports, bi admin, DSN, 64 bit, 32 bit  , KBA , BI-BIP-CRS-FUN , Admin, Viewing & Scheduling Reports , Problem

Product

SAP Crystal Server 2020