Symptom
Since February 2025, suppliers cannot be recognized during Supplier Invoice Scanning.
Environment
SAP Business ByDesign 2502
Reproducing the Issue
- Go to Supplier Invoicing work center.
- Go to Invoice Scanning view.
- Upload PDF invoices.
- Supplier cannot be recognized after scanning completed.
Cause
Cause of the issue is from Document Extraction Service during Automatic Master Data Synchronization through backend which runs everyday. It deletes the supplier master data from data base so no suppliers can be found during invoice scanning.
Resolution
The issue is fixed by hotfix on 15/16 March, 2025.
To enable the fix to work and Suppliers getting recognized during Supplier Invoice Scanning, below steps need to be performed.
- Go to Application and User Management work center.
- Go to Master Data Synchronization view.
- Select Supplier Record and do Start Synchronization. Active Suppliers will be pushed to Document Extraction Service. This activity need to be performed only one time.
- Perform Supplier Invoice Scanning and observe for Supplier recognition. Monitor Supplier Invoice Scanning for two days.
In case the Suppliers still cannot be recognized, report a case to SAP.
Keywords
Scanning Invoice, Supplier Missing, Supplier Not Recognized, Master Data Synchronization , KBA , AP-SIP , Supplier Invoice Processing , Problem