SAP Knowledge Base Article - Public

3588993 - Supplier Cannot Be Recognized During Supplier Invoice Scanning Since 2502

Symptom

Since February 2025, suppliers cannot be recognized during Supplier Invoice Scanning.  

Environment

SAP Business ByDesign 2502

Reproducing the Issue

  1. Go to Supplier Invoicing work center.
  2. Go to Invoice Scanning view.
  3. Upload PDF invoices.
  4. Supplier cannot be recognized after scanning completed.

Cause

Cause of the issue is from Document Extraction Service during Automatic Master Data Synchronization through backend which runs everyday. It deletes the supplier master data from data base so no suppliers can be found during invoice scanning.

Resolution

The issue is fixed by hotfix on 15/16 March, 2025.

To enable the fix to work and Suppliers getting recognized during Supplier Invoice Scanning, below steps need to be performed.

  1. Go to Application and User Management work center.
  2. Go to Master Data Synchronization view.
  3. Select Supplier Record and do Start Synchronization. Active Suppliers will be pushed to Document Extraction Service. This activity need to be performed only one time.
  4. Perform Supplier Invoice Scanning and observe for Supplier recognition. Monitor Supplier Invoice Scanning for two days.

In case the Suppliers still cannot be recognized, report a case to SAP.

Keywords

Scanning Invoice, Supplier Missing, Supplier Not Recognized, Master Data Synchronization , KBA , AP-SIP , Supplier Invoice Processing , Problem

Product

SAP Business ByDesign 2502