Symptom
The CICO employee synchronization does not work either via triggering full sync through Clock In Clock Out Employee Full Synchronization Details object from Manage Data, or from quick fix from Check Tool > Clock In Clock Out employees are synchronized.(EmployeeDataSyncrhonized).
You may face error "We encountered an unexpected error during employee sync. Please contact your system administer."
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Time Tracking
Reproducing the Issue
Execute Clock In Clock Out Employee Synchronization
- either by Clock In Clock Out Employee Full Synchronization Details in Manage Data.
- or by Quick Fix from Clock In Clock Out employees are synchronized.(EmployeeDataSyncrhonized) in Check Tool.
Then it is noticed the synchronization does not work and cannot get CICO employees synchronized.
Cause
This is because the picklist for employee status is not following the expected standard name.
We understand that there may be customer requirement to use a custom picklist for employee status, so we are working to enhance our codes so that we also consider custom employee status picklist for employee status.
But before the source code is available, please make sure both the Legacy Picklist ID and Code are employee-status exactly all in lower case (No capital letter at all!) and with hyphen in between.
Resolution
We are working to provide source code improvement so that custom employee status picklist is also supported.
But before the source code improvement is deployed, in order to ensure successful CICO employee synchronization, please make sure both the Legacy Picklist ID and Code are employee-status exactly all in small letters (No capital letter at all!) and with hyphen in between.
Steps below can be referred to,
- Go to Picklist Center.
- Search for employee status picklist you use.
- Select the employee status picklist and click on Edit.
- Make sure the Code and Legacy Picklist ID are both maintained exactly as employee-status and Save.
No capital letter is allowed! And the hyphen must exist between employee and status! - Make sure the same picklist name employee-status is also used in your Corporate Data Modal.
More details can be found in Picklist Configuration for Employee Status and Job Relationship Type
See Also
2786336 - Picklists Values duplicated with ~%1 - Post Picklist Migration
Keywords
CICO, sync, Clock In Clock Out Employee Full Synchronization Details, punch, failed, time, events, does not exist, not synced, not synchronized, manage clock in clock out, EMPLOYEE_SYNC_CONFIGURATION, check tool, EmployeeDataSyncrhonized, employee, synchronization, failed, synchronised, synchronise, Trigger Full Synchronization, Trigger Full Synchronisation, import, tracking, clock, capital, big, upper case, lower case, We encountered an unexpected error during employee sync, Please contact your system administer. KI2505, TIM-49751, TIM-49462 , KBA , LOD-SF-TTR-CIO , Clock In/ Clock Out , Known Error