Symptom
When trying to rate on forms, is it possible to give a ratings to users based on rules/definitions?
For example:
"If employee is at the company for less than 6 months, can the rating be: "Too New To Rate", if employee is at the company for more than 6 months a rating should be given manually.
Environment
SAP SuccessFactors HCM, SAP SuccessFactors Performance & Goals
Reproducing the Issue
- Create a form template with the option of rating enabled.
- Launch template for a user.
- Notice that rating can only be given or set a default value, but logic-based rating is not possible.
Cause
Expected behaviour by current system design.
Resolution
Currently it is not possible to rate on forms based on rules/definition. The only available option is to set a rating value as default, based on the following implementation guide:
Customized Default Rating and Unrated Rating
If this is a feature that you would like to see altered you may raise an enhancement request, following: https://me.sap.com/notes/2090228/E which outlines the process of raising an enhancement request.
See Also
Keywords
Performance Form Rating, Overall Performance Form Rating, Performance Form Item Rating, SAP SuccessFactors Performance & Goals, Enhancement Request, 360 Form Rating, 360 Forms Rating, 360 Form Item Rating, SG, SuccessFactors, Rating, Rating Scale , KBA , LOD-SF-PM-RAT , Ratings and Weights , LOD-SF-PM-FF , Form Features, RTE, Spell Check, Legal Scan, Print , LOD-SF-MTR-FF , Form Features, RTE, Spell Check, Legal Scan, Print , LOD-SF-MTR-FRM , Forms and Templates , LOD-SF-PM-FRM , Forms & Templates , LOD-SF-MTR-RAT , Ratings and Weights , How To