SAP Knowledge Base Article - Public

3589630 - An Approver Cannot be Determined in Customer Invoice created for a Contract.

Symptom

You have enabled the approval for Customer Invoice and defined the approval process. However, when you release a Customer Invoice for a Customer Contract via Customer Contract Invoice Request or Scheduled Invoice Request, the approval process is not triggered. The invoice is created and released directly.

Environment

SAP Business ByDesign 2502

Reproducing the Issue

  1. Go to Customer Invoicing work center.
  2. Go to Invoice Documents.
  3. Search for Invoice ABC(ABC is the ID of the Customer Invoice).
  4. You can see approval status is Approval not necessary.
  5. However you have set up the approval process for customer invoicing, you expect the Customer Invoice to go for Approval.

Cause

The Approval Processes for Customer Invoices are only triggered when created manually. This means that a Customer Invoice generated from a Customer Contract will not be sent for Approval. The Customer Invoice will only be sent for Approval when it is created from a Manual Invoice Request.

Resolution

This is the standard system behavior. If you require approval for all business processes that lead to customer invoicing, you can set up approvals earlier, such as on the customer contract, to control the information included on the customer invoice. However, it is not possible to set up an approval process for a customer contract.

Keywords

Approval Process; Customer Contract Invoice Request; Scheduled Invoice Request; Customer Invoice; Manual Invoice Request; Triggered , KBA , SRD-CRM-INV , Customer Invoicing , Problem

Product

SAP Business ByDesign 2502