Symptom
The "Equal To" operator does not function correctly when using the Advanced option in fixed value selection.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Pre-Requisites: Ensure you have a customer and field selected for Fixed Value Selection in the report.
- Edit the report via the report wizard and click on Fixed Value Selection.
- Click on Advanced.
- Select "_Include Group".
- Choose the required values with the condition "Equal To" and click OK.
- Observe that nothing happens when clicking OK.
Cause
- The field type is "Multivalue".
- Multivalue fields do not support the "Equal To" operator.
Resolution
Use the "Contains" operator to save the condition.
Keywords
multi-value field issue, fixed value selection, analytics tools, advanced selection, equal to operator, contains operator, report wizard, include group, cloud for customer, C4C analytics, ByD analytics, Travel analytics, field type limitation, troubleshooting, operator functionality, resolution , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , Problem
Product
SAP Cloud for Customer add-ins all versions
SAP Knowledge Base Article - Public