Symptom
The error message shows that 'name' and 'role code' are required after being imported by the Data Impex Tools, even though these values are already filled in the Import template.
Environment
SAP Sales and Services Cloud Version 2
Reproducing the Issue
- Go to All Settings.
- Search Import and Export Date.
- Click the Import - Create.
- Choose one of the entities.
- Import the CSV file that has been maintained.
- Then, the error message will occur.
Cause
The imported tasks failed due to incorrect data format. A new line added in the data of a specific column for a record is not supported.
To add a new line, the newline character in the data - "\n" needs to be used.
For example:
The record line without newline character (data gets into two lines, which gets treated as separate records) :
TEST123,,,CRM000,,,ACTIVE,,,,,,,TEST ACCOUNT,,,,,,,,,,CN,13,225212,BEIJING,"CHAOYANG Building,LAO JIE Century Park
",,,,,,,,,FALSE,,,,,,,0,FALSE,cn,,,,,TESTuser@outlook.com,www.google.com,,,12345678,,123113,
How it should be:
TEST123,,,CRM000,,,ACTIVE,,,,,,,TEST ACCOUNT,,,,,,,,,,CN,13,225212,BEIJING,"CHAOYANG Building,LAO JIE Century Park\n",,,,,,,,,FALSE,,,,,,,0,FALSE,cn,,,,,TESTuser@outlook.com,www.google.com,,,12345678,,123113,
Resolution
- Check the imported data file.
- Identify the records with the incorrect data format.
- Correct the data format by replacing the new line character with "\n".
- Save the changes in the data file.
- Re-import the data file.
See Also
Keywords
SAP Service Cloud Version 2, Data Import, Account Data, Data Format, Newline Character, Role Code, Name, Mandatory Fields, SAP Sales Cloud Version 2, CSV , KBA , CEC-CRM-IMX , Data Import/Export for SAP Sales/Service Cloud , CEC-CRM-ACC , Account for SAP Sales/Service Cloud , How To