Symptom
When trying to install the Groupware Add-in in Groupware Settings, It returns the error message:
Exchange Operation Failed. The Remote Server Returned An Error: (403) Forbidden
Environment
SAP Sales Cloud Version 2
Reproducing the Issue
- Go to settings.
- Open Groupware settings.
- Navigate to specific user.
- Try to install the add-in for this user.
- Error.
Cause
Unfortunately there is a current limitation where the add-in cannot be installed here for users using the App-only Access.
SAP are working to fix this in future release.
Resolution
In the meantime, it is recommended to install the add-in using the manifest file.
Go to Groupware settings -> Tenant Settings -> download/ Export the Manifest file.
Then:
Have your exchange admin deploy it:
- Navigate to Settings → Integrated apps.
- Click Upload custom apps and select Deploy Add-in.
- Choose Upload custom apps and click Next.
- Select I have a manifest file (.xml) for the app and click Upload.
- Browse and select your manifest.xml file.
- Choose who will get access:Entire organization (recommended for company-wide deployment). Or Specific users/groups (for limited access). Or Just me (for testing purposes).
- Click Next and confirm the settings.
Keywords
Groupware, Outlook, Sales, Cloud, Version 2, V2, Add-in, Addon, Plugin, Exchange, Error, 403 , KBA , CEC-CRM-GW , Groupware for SAP Sales/Service Cloud , Problem