SAP Knowledge Base Article - Public

3589958 - Incorrect Output History for Cancelled Purchase Orders

Symptom

The output history for a cancelled Purchase Orders is being sent via email, despite the expectation that they should be marked as "Do not send".

Environment

SAP Business Bydesign 

Version 2502

Reproducing the Issue

  1. Go to the Purchase Requests and Orders Work Center
  2. Go to the Purchase Orders View
  3. Filter for All Purchase Orders
  4. Search for the Purchase Order ID
  5. Open the order
  6. Navigate to the Output History tab
  7. Observe that a cancellation PDF file has been sent.

Cause

The output channel for the vendor in the supplier master data is set to email. This setting applies to all POs, including cancelled ones.

Resolution

  1. Open the supplier master data for the respective Vendor .
  2. Go to the communication tab and then the collaboration subtab.
  3. Select "Purchase order" under the business document name. Output channel settings are empty and no output channel is maintained. Hence the generic output channel maintained in application and user management work center will be picked up automatically. 
  4. For the system to pick the output as Do not send, remove the output settings at the supplier master data level. And maintain the output settings as Do not send in the Application and User Management work center. 
  5. The system will now pick up the output settings maintained at the Application and User Management work center.

See Also

  • KBA: 2678740 - How is the Output Channel of a Purchase Order Determined
  • SAP Community: [How is the Output Channel of a Purchase Order Determined?](https://community.sap.com/t5/enterprise-resource-planning-q-a/how-is-the-output-channel-of-a-purchase-order-determined/qaq-p/14022729)

Keywords

Output History for Cancelled Purchase Orders, Do not send, Output Channel , KBA , AP-POP , Purchase Order Processing , Problem

Product

SAP Business ByDesign all versions