SAP Knowledge Base Article - Public

3590370 - Unable to upload Product group via Data workbench

Symptom

Unable to upload Product Groups via Data workbench.

Environment

SAP Cloud for Customer.

Reproducing the Issue

  1. Navigate to Data workbench >Product WC 
  2. Click on Product Administration>> Select Product >> Sales>> Product Groups.

Product Group is a standard field and is not available in Data workbench to upload data.

Cause

This is a technical limitation.

Resolution

PRODUCT_GROUP is NOT supported on OData and Data Workbench.

This is not a bug, but a limitation.

Currently there are two options as a workaround.

  1. If an ERP/S4 System is used, the products should be replicated from there using our replication SOAP service. This MaterialReplicationIn SOAP service might be "misused", if no ERP/S4 is the source of the products. This is an internal API, so usage is on the customer's own risk!

  2. A workaround using PDI by
    1. Extending the SalesProcessInfo Node of the product with own extension fields for the product group 1-5 (if needed) and also include them in the OData/Rest API
    2. Setting up a PDI implementation which, when modifying the SalesArea/Product Group node transfers the product groups data form the extension fields into the standard fields (potentially also clearing the extension field data)
    3. Optional: removing the extension fields if not needed anymore

Keywords

Product Group,Datawork bench. , KBA , LOD-LE-PRD-PRD , Product + Product Category Hierarchy , Problem

Product

SAP Cloud for Customer core applications 2502