Symptom
Issue to post Credit Memo or Supplier Invoice error message "Product blocked and should not be used for new processes".
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Supplier Invoicing on Work Center.
- Go to Invoices and Credit Memos view.
- Search for Credit Memo ID.
- Click edit and View All button.
- Click Check button.
- The error message
"Product blocked and should not be used for new processes" .
Cause
When a product item in Master Data has the status "Blocked", it is unavailable for creating new documents.
Resolution
Follow the steps bellow to unlock the product.
- Go to Product Portfolio on Work Center.
- Go to Products view.
- Select the respective type of product "By Material" or "By Service".
- Search for The Product ID.
- Click Edit and view All button.
- Navigate to Purchasing tab.
- On Status Field select the Active option and Save button.
Upon completion of the outlined steps, posting of the Supplier Invoice or Credit Memo may be attempted.
Keywords
Product Blocked, Supplier Invoice cannot post, Credit Memo, Cannot post , KBA , SRD-SRM-PRO , Purchase Requests and Orders , Problem
Product
SAP Business ByDesign all versions