SAP Knowledge Base Article - Public

3590633 - Approval Process is not working for new version of Sales Quote

Symptom

When creating a new version for a Sales Quote, the approval process cannot be triggered.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Sales > Sales Quotes.
  2. Create new and send for approval.
  3. Once Quote is approved, go to Versions tab.
  4. Click new.
  5. Is not possible to send it for approval.

Cause

The behavior when creating a new version of a Sales Quote (via the "Versions" tab > "New") differs from copying a Sales Quote (via "Actions" > "Copy" > "Save").

When creating a new version, all the data from the previous Quote, including the Approval Status, is copied exactly as it is. This means that if the original Quote has already gone through the approval process and has Approval Status = "Approved", the new version will automatically have the "Approved" status and will not go through another approval cycle.

On the other hand, when copying a Quote, not all data is carried over, including the Approval Status, which will be set to "Not Started." Allowing to submit the new Sales Quote for approval at a later time.

Resolution

This is the expected system behavior.

For sending/submitting the Sales Quote for approval, please use the "Copy" action instead.

See Also

3536162 - Submit for Approval button disabled for sales documents

2540377 - FAQ for Sales Quotes

Keywords

Submitted, sent, not triggering, Sales Order , KBA , LOD-LE-CQP , Customer Quote Processing , Problem

Product

SAP Cloud for Customer core applications all versions