SAP Knowledge Base Article - Public

3590659 - Error TSV_TNEW_PAGE_ALLOC_FAILED when using Sales APIs in SAP S/4HANA Cloud Public Edition

Symptom

After running a Sales API to create many sales documents at the same time/creating sales orders with multiple line items the error TSV_TNEW_PAGE_ALLOC_FAILED is appearing.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Using any of the Sales APIs, your payload is asking for a huge number of documents (a Sales Order with multiple line items, multiple Sales Orders...)
  2. Try to run the payload and receive the TSV_TNEW_PAGE_ALLOC_FAILED error message

Cause

Standard system design.

The error TSV_TNEW_PAGE_ALLOC_FAILED occurs when a request exceeds the system’s memory limits.

In SAP S/4HANA Cloud Public Edition, all system parameters are fixed across all cloud systems, whether production or non-production and cannot be altered for a single API. These limits are there to ensure stability.

Resolution

Decrease the volume of data being created/processed in the payload request.

This could include refining the request, applying additional filtering, or adjusting how data is processed to reduce its size. (Example, Sales orders with less line items, decrease the volume of sales documents being created, use batch requests to divide the Sales Orders with multiple line items in smaller chunks of data...) 

See Also

Sales APIs

Batch Requests

Keywords

APIs, TSV_TNEW_PAGE_ALLOC_FAILED, memory, allocation, performance, parameters, alter, add, payload, API_SALES_ORDER_SRV, API_SalesOrder, Sales Order API A2X V4 , KBA , SD-SLS-SO-MO-2CL , Make-to-order, assembly order (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions