SAP Knowledge Base Article - Public

3591147 - An error message : "SZADR_ADDR1_COMPLETE-ADSMTP_TAB-ADSMTP-SMTP_ADDR is a required entry field"

Symptom

An error message "SZADR_ADDR1_COMPLETE-ADSMTP_TAB-ADSMTP-SMTP_ADDR is a required entry field" is encountered when trying to add a customer or supplier role to the Business Partner.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Go to the 'Manage Business Partner Master Data' app
  2. Open the Business Partner
  3. Navigate to the Roles tab
  4. Create a Business Partner Role as customer or supplier
  5. An error message 'SZADR_ADDR1_COMPLETE-ADSMTP_TAB-ADSMTP-SMTP_ADDR  is a required entry field' appears

Cause

For the supplier or customer account group, which is linked to the BP account group of the affected Business Partner, the "Internet mail address" field has been set as a "Required entry."

Resolution

Enter a value for "Internet mail address" in the BP address communication data or alternatively, change the settings in the Configuration activity 103050 - Define Account Groups with Screen Layout (Customers) for the Customer account group > General Data > Communication > set "Internet mail address" to "Opt. entry".

Keywords

S/4HANA, Cloud, Public Edition, Business Partner, BP, SZADR_ADDR1_COMPLETE-ADSMTP_TAB-ADSMTP-SMTP_ADDR, required entry field, customer role, supplier account group, internet mail address, configuration activity 103050, account groups, screen layout, communication, opt. entry. , KBA , LO-MD-BP-2CL , Business Partners for Public Cloud , BC-SRV-ADR , Address Management / Business Address Services , LO-MD-BP , Business Partners , Problem

Product

SAP S/4HANA Cloud Public Edition all versions