Symptom
An error message 'Start date must not be after end date; Save failed' appears while trying to release Outbound Delivery.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Outbound Logistics Work Center.
- Navigate to the Outbound Deliveries View.
- Search for the Outbound Delivery.
- Choose Release, then the mentioned message would occur.
Cause
The issue arises due to the automatic warranty assignment being enabled but the recording of registered products sold is not enabled.
- Go to the Business Configuration Work Center.
- Navigate to the Implementation Projects View.
- Select the Project.
- Select Edit Project Scope.
- Go to the Question tab by selecting Next.
- Expand Service, Entitlement Management.
- Select Warranty Entitlement, the question 'Do you want the solution to automatically assign warranty for registered products sold during the outbound delivery process?' is scoped.
- Select Registered Products, the question 'Do you want the solution to automatically record registered products sold during the outbound delivery process?' is NOT scoped.
This results in an issue during warranty assignment, causing the end date for the warranty period not to be proposed.
Resolution
After scoping the highlighted question and saving the change, no errors will occur during the release of the outbound delivery.
See Also
2416594 - Warranty not assigned automaticaly in Outbound Logistics
Keywords
Outbound Delivery, Outbound Logistics, Release, Error, Start date, End date, Save failed, Warranty assignment, Registered products, Business Configuration , KBA , AP-ODP-OD , Outbound Delivery , Problem