Symptom
A workflow has five steps, custom email notification is configured in the previous four steps. As per the customer email notification, the initiator should receive a custom email when a step is approved. However, when the fourth step approver approved the workflow, the initiator did not receive any email notification
Environment
SAP SuccessFactors Employee Central - Workflow
Reproducing the Issue
- A workflow has five steps of approval
- Custom email notification is configured in the previous four steps and there is no custom email notification configured in the final step
- According to the configuration, the initiator should receive a customized email when any step is approved
- The initiator received the customized email upon the previous three steps being approved. However, in the fourth step, customized email was not received
Cause
This is expected. The logic of sending email notification for workflow is that when step N is approved, the system will send email according to the email configuration of step N+1, namely finding the email template and email receiver of step N+1 and send emails accordingly.
Hence, when the system is about to send email notification when the step 4 is approved, the system will start to search for email configuration in step 5, if the configuration is missing, or in step 5, notification to initiator is off, the email notification will not be sent to the initiator.
Resolution
This is an expected behavior
See Also
Keywords
SAP SuccessFactors, employee central, workflow, initiator, custom email notification, first step approver, INC11289180 , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , How To
SAP Knowledge Base Article - Public