SAP Knowledge Base Article - Public

3591359 - Initiator of the workflow not receiving custom email notification

Symptom

Initiator of the workflow should receive custom email notification once the first step approver approve the workflow.

Environment

SAP SuccessFactors Employee Central - Workflow

Reproducing the Issue

  1. Initiate a workflow which has two step approvers.
  2. Custom email notification is configured in the first step.
  3. After first approver approve the workflow, custom email notification is not sent to the initiator.
  4. But if the custom email notification is configured in the second step.
  5. After first approver approve the workflow, custom email notification is sent to the initiator.

Cause

According to the logic, the system first completes the transition and then handles the email.Once the transition is complete, the system moves to step 2 approver, adhering to the email configuration for this step.

Resolution

This is an expected behavior

See Also

https://itsm.services.sap/now/nav/ui/classic/params/target/kb_view.do%3Fsysparm_article%3DKB0779747

2877411 - Some CC Role Types receive the Custom Workflow Notifications while others receive the Standard Workflow Notifications

Keywords

SAP SuccessFactors, employee central, workflow, initiator, custom email notification, first step approver, INC11289180 , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , Known Error

Product

SAP SuccessFactors Employee Central 2411