SAP Knowledge Base Article - Public

3592324 - SAC story scheduled doesn't show all content, some widgets are missing

Symptom

  • The SAC dashboard, which is scheduled for daily publication to users, has been missing some widgets;
  • The issue does not occur when the dashboard is manually exported into PDF format.

 

Environment

SAC Analytics Cloud 2025.1.10

Reproducing the Issue

  1. Log into SAC 
  2. Open the Story > schedule a publication > select PDF type > Create
  3. The schedule occurs successfully, but the PDF is missing some widgets or they are corrupted in some pages.
  4. If the schedule happens only with the pages where the widgets are not coming, all of them come. 
  5. The manual export is working fine.

The same behavior occurs with PPT files.

Cause

From the HAR file collected, the widgets are not being displayed because some GetResponse calls are taking too long and eventually time out. In SAP Analytics Cloud, there is a maximum waiting time of 5 minutes for these calls. If the system does not receive a response within this limit, the request fails, which causes the widgets to stop rendering.

This timeout is built in to prevent runaway queries that will consume backend resources. 

Resolution

This behavior will be improved in the next QRC4 (November), when the logon timeout will become configurable, allowing the setting to be adjusted based on specific requirements.

See Also

Keywords

SAC, schedule, error, widgets missing, bug, BW live, PDF, PPT, Analytics, Cloud, timeout, backend , KBA , LOD-ANA-SCH , SAC Story Scheduling and Publication , Problem

Product

SAP Analytics Cloud 1.0