SAP Knowledge Base Article - Public

3592694 - Error: Enter Primary Contact is shown in Leads despite the Primary Contact being maintained

Symptom

After marking certain fields as mandatory in Leads, an error is still thrown when creating the Lead despite the relevant field being maintained. This can apply to any field in Leads under Primary Contact (such as email address).

Environment

SAP Sales Cloud Version 2

Cause

Primary Contact is a calculated association, and hence it wont be possible to directly enable the mandatory flag for any fields here.  This is because the values are calculated after the processing of any determinations or validations.

Resolution

Under Extensibility Administration, create a Dynamic Property for the Lead field that is required to be mandatory.

See Also

leads, mandatory field leads, lead primary contact

Keywords

KBA , CEC-CRM-LEA , Lead for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0

Attachments

Pasted image.png