SAP Knowledge Base Article - Public

3592802 - Unable to View Values in Dropdown Lists in Custom Tasks - Onboarding

Symptom

External users are unable to view the values in the dropdown lists within a custom task.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Log in to the system as an external user.
  2. Open the Custom Task.
  3. Attempt to fill in the details using the dropdown for the available fields.
  4. Notice that the dropdown list is empty and shows "None" only.

Cause

The issue is caused by the absence of externalName in Manage Data for the custom picklist. The system attempts to select the externalName when an external user opens the dropdown. However, because the externalName are not entered in Manage Data, the system is unable to display them.

Resolution

  1. Navigate to the Manage Data > search for the Custom Picklist.
  2. For each picklist value, add an externalName.
  3. Save the changes.
  4. Restart the onboarding process for already created external users or create new external users to see the changes.

If necessary, also review the article on how to create a custom Onboarding or Offboarding task: Custom Tasks in Onboarding and Offboarding - SAP Community

See Also

Custom Tasks in Onboarding and Offboarding - SAP Community

Keywords

unable, view, values, information, data, dropdown, lists, custom, task, tasks, in, picklist, externalName, none, empty, Manage Data, candidate, onboardee , KBA , LOD-SF-OBX-NHA , New Hire Activities (activities, tasks, buddy, equipment) , Problem

Product

SAP SuccessFactors Onboarding all versions