Symptom
- Error message "500 No authorization to call the transaction MMPV Start of transaction failed" is displayed when attempting to open the app "Close Periods".
- Unable to open "Close Periods" app in Production (PROD) environment, even though it can be opened in the TEST environment.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Log in using a CBUser with an Assigned Business Role that includes the Business Catalog "SAP_CMD_BC_PR_ADMIN_PC" or "SAP_RFM_BC_PR_ADMIN_PC" with Access Category with "Write" level set as "No Access" or "Restricted"
- Search for and open the app "Close Periods"
- Popup message with error appears, and the app do not open
Cause
The user does not have the authorization level required to open the "Close Periods" app.
The user has a Business Role, that includes the Business Catalog "SAP_CMD_BC_PR_ADMIN_PC" or "SAP_RFM_BC_PR_ADMIN_PC", with Access Category with "Write" level set as "No Access" or "Restricted".
Resolution
Use the app "Maintain Business User" to assign the specified CB User a Business Role with one of the following Business Catalogs, with access level for "Write, Read, Value Help:" set as "Unrestricted":
- SAP_CMD_BC_PR_ADMIN_PC, Master Data - Administration
- SAP_RFM_BC_PR_ADMIN_PC, Retail Master Data - Product Master Administration
For reference, these business catalogs can be found on the following SAP business roles, by default:
- SAP_BR_MD_SPCLST_ITEM_RFM, Master Data Specialist - Product Data (Retail)
- SAP_BR_PRODMASTER_SPECIALIST, Master Data Specialist - Product Data
See Also
Keywords
MMPV, authorization, access level, business role, business catalog. , KBA , LO-MD-MM-2CL , Product Master for Public Cloud , Problem