Symptom
Multiple Benefit Claim Accumulation records are being created within the same period for the same employee, which results in employees claiming more than the entitled amount.
Environment
SAP SuccessFactors Employee Central - Global Benefits
Reproducing the Issue
- Initiate and submit multiple claim requests for a user to trigger the approval workflows.
- Login as the approver and mass approve the claim requests.
- More than one Benefit Claim Accumulation record is created for the same user.
Cause
Discrepancies in Benefit Claim Accumulation data may occur when claim requests are mass approved.
Resolution
This is currently a limitation. Engineering team has identified a solution which is tentatively scheduled for the 2H 2025 release cycle.
Please refrain from using mass approval for claim requests until the issue is fixed.
As a workaround, please use the following approach to fix the benefit claim accumulation data issue:
- Export the Benefit Claim Accumulation and Benefit Employee Claim records via Import & Export Data
- Delete the incorrect Benefit Claim Accumulation records via an import
- Delete the benefit employee claim record (that was associated with the incorrect benefit claim accumulation record) via an import
- Re-import the benefit employee claim record (with or without the same external code).
- Once the import is completed successfully, the claim should get associated with the correct (i.e., already existing) accumulation record
Keywords
SAP SuccessFactors Employee Central, Global Benefits, Benefit Claim Accumulation, multiple, same period, mass approval, claims, CS20250009340156, BEN-19548, INC11308929 , KBA , LOD-SF-EC-GBF , Global Benefits , Known Error