SAP Knowledge Base Article - Public

3594733 - Business Partner Replication Failure with Connection Termination Error Message

Symptom

You are trying to replicate a particular Account from S4H to Sales or Service Cloud Version 2 but the following error is raised in the message monitor for the respective payload:

"code": "503",
            "message": "\"upstream connect error or disconnect/reset before headers. reset reason: connection termination\""
        }
    ],
    "errorDetailsAsJson": "[{\"code\":\"503\",\"message\":\"\\\"upstream connect error or disconnect/reset before headers. reset reason: connection termination\\\"\",\"details\":[],\"errorDetailsAsJson\":null}]"

Environment

S4 Hana

Sales Cloud Version 2

Service Cloud Version 2

Reproducing the Issue

  1. From your source system, replicate the Account to CNS;
  2. log on on CNS
  3. go to Settings
  4. go to Message Monitoring
  5. the respective message of businessPartnerS4ReplicationMessageIn remains under Pending Retry for a while, until turn into error state. 

Cause

The payload runs in error (time out) due to very high the number of addresses included in the Business Partner master data.  

Resolution

The system is not able to process a very high number of postal addresses consistently. You need to restrict the number of addresses assigned to the account or even keep the main address only. 

We have Updated validation logic to include address information checks with a threshold of 500 addresses.

This pull request aims to prevent the creation of accounts with an excessive number of addresses, thereby maintaining system performance and data quality.

Please consider as well:

In case you have an Account already replicated to Sales and Service Cloud Version 2 along with more than 500 postal addresses, consider the following behavior:

 1.            In case we make any changes to the account, will the update fail in Version 2, due to the 500 limit check that has been added? 

Answer: All changes are possible except for adding additional addresses to the account. Only a create of address is triggering the validation

2.            If the Business Partner is updated in S4H, will the change not be reflected in User Interface, as the message monitoring would fail? 

Answer: All changes from S/4 are accepted except for adding of additional addresses.

The guardrail check prevents creation of additional addresses >500 instances, but it does not raise an error for all changes.

See Also

There are possible workarounds you can adopt, based on your requirement, such as:

    1. Implement logic in the S4H BADI to filter out addresses in the S4H Outbound replication. This will help prevent the deletion of records in the inbound message in S4H when there is an update in the CNS Business Partner.
    2. Filter out the Address Type Object in S4H to retain only the Default Address (DRF). This process is effective for one-time replication from S4H to CNS.

Keywords

connection termination;cns;postal address;addressinformation;address; , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , CEC-CRM-ACC , Account for SAP Sales/Service Cloud , Known Error

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0