Symptom
When trying to delete an entry in an SSCUI/Configuration Activity, the system is displayed the following error message:
"Deletion not possible for record created by SAP."
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the affected SSCUI/Configuration Activity
- Select the entries provided by SAP
- Try do delete the selected entries
- Error message is displayed
Cause
In any SSCUI/Configuration Activity, standard entries created by SAP cannot be deleted due to possible inconsistencies and compliance conflicts. This is the current system behavior.
Resolution
As the deletion of entries created by SAP is not possible, for the entries that won't be used, edit these entries with "DO NOT USE" in their name.
See Also
To check if an SSCUI/Configuration Activity supports the deletion of customer records, search for the affected SSCUI in file Configuration Activity.xlsm (SAP Customer) located in the Road Map Viewer under the Explore Phase and check the value for the "Delete Customer Records" field.
If the field has the "Deletion not supported" value, then customer created records also cannot be deleted.
Keywords
SSCUI, cannot delete, Deletion, not possible, record created, by SAP, Configuration Activity, delete entries , KBA , SV-CLD-FRM-CIC-MYS , Manage Your Solution , SV-CLD-SSC , Self-Service-Configurations-UI , Problem