Symptom
After enabling the 'EC alert and Notification' for the first time, the system triggered old cancelled notifications from Employee Time object.
Environment
SAP SuccessFactors Employee Central
SAP SuccessFactors Employee Central Time Off
Reproducing the Issue
Enable in Provisioning the 'EC alert and Notification' for employee time objects for 1st time
1) To enable the Job, please check the following steps:
-
Log on to SAP SuccessFactors Provisioning and select the relevant company.
-
Go to Managing Job Scheduler and select Manage Scheduled Jobs.
-
Choose Create New Job.
-
Enter Job name and Job Owner.
-
Select Job type as Off Cycle Event Batch Processing Job.
-
In the Job Occurrence and Notification section, choose the radio button Recurring: Choose the frequency for the job to recur as daily.
-
Enter Time.
-
Enter the Start Date.
-
Choose Create and Submit the Job.
-
To Schedule the EC and Alerts notification Job, repeat the above steps. In this case, you would need to choose the job type as EC Alerts and Notifications.
- NOTE: Please note that customers do not have access to provisioning, to execute the above steps, please reach out to your Implementation Partner or SAP product support.
2) After the EC Alerts and Notifications job is enable, check the old pending alert being sent by the system.
Cause
The Employee Time object is a non-effective-dated object. In this case, the system uses a hardcoded mechanism to automatically delete old alerts if there is a change made to the same absence record for which a previous alert was created.
According to the standard system design, the EC Alerts and Notifications Job is responsible for processing both current and backlog alerts, but as the Job wasn't enable, it created a backlog of alerts that were created but never processed, because EC Alerts and Notification Jobs were not executed or not created in the system.
After enabling the Job, the backlog was processed and sent by the system.
Resolution
In a scenario where few old alerts are pending, it is feasible to delete them manually using the multi-select option on the Manage Alerts and Notifications page.
However, if the environment has thousands of such old alerts records, it's advisable to contact the Engineering Team to explore the feasibility of deleting those alerts via a script execution.
Recommended Approach
If you notice that the EC Alerts and Notifications Job has failed, has not been executed for several days, or was never set up, follow this approach:
-
Manually delete old pending alerts: (Before processing or creating the EC Alerts job)
-
Navigate to: Manage Alerts and Notifications
-
Use the filter: "Alert Effective Date"
-
Select all relevant old alerts
-
Click the Delete option (located at the top-right corner) to remove all selected alerts
-
-
Best Practices to Avoid Future Issues:
-
It is highly recommended for implementation partners and partner support teams to:
-
Schedule the EC Alerts and Notification Job during the alert rule configuration process.
-
This ensures alerts are processed in real-time, minimizing processing delays.
-
-
Daily monitoring of the job status is crucial to proactively identify failures or missed executions.
-
-
Set Up Email Notifications for Job Status:
-
Go to: Provisioning System > Manage Scheduled Jobs > EC Alerts and Notification > Edit
-
Add the email addresses of EC Admins or Time Admins
-
Enable the following options:
-
Send an email when the job starts
-
Send an email when the job completes
-
Send an email when the job fails
-
-
By following these best practices, you can effectively prevent similar issues in the future and ensure timely processing of alerts.
See Also
Keywords
Time off, EC Alerts and Notification, Old pending alerts, Employee time, email, EC Job, , KBA , LOD-SF-EC-TIM-WAN , Workflows - Alerts - Notifications , How To
SAP Knowledge Base Article - Public