Symptom
You are receiving an error popup in the UI labelled, "Server specific error occurred!", when attempting to edit the Rules and Messages of a product which they have synched from the backend.
Environment
SAP SALES CLOUD CPQ
Reproducing the Issue
- Go to Setup > Products.
- Search for a Product.
- Go to product version and edit the active one.
- On the product, click on Rules and Messages.
- Getting error 'Server specific error occurred!'.
Cause
- There is an issue with calls to visibilityPermissions API.
- A value has been added to the field "actionType" of 'DISALLOWVALUES' which is incorrect.
Resolution
- It should not be in capital letters it should be set as 'DisallowValues'.
- Please engage CPQ Support Team for further assistance on existing issues.
See Also
Keywords
backend, synch, VC, KB, Product, server , Fatal, error , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Bug Filed
Product
SAP CPQ 2025