SAP Knowledge Base Article - Public

3595841 - Fatal: When attempting to edit the Rules and Messages of a product synched from backend

Symptom

You are receiving an error popup in the UI labelled, "Server specific error occurred!", when attempting to edit the Rules and Messages of a product which they have synched from the backend.

Environment

SAP SALES CLOUD CPQ

Reproducing the Issue

  1. Go to Setup > Products.
  2. Search for a Product.
  3. Go to product version and edit the active one.
  4. On the product, click on Rules and Messages.
  5. Getting error 'Server specific error occurred!'.

Cause

  • There is an issue with calls to visibilityPermissions API.
  • A value has been added to the field "actionType" of 'DISALLOWVALUES' which is incorrect.

Resolution

  • It should not be in capital letters it should be set as 'DisallowValues'.
  • Please engage CPQ Support Team for further assistance on existing issues.

See Also

visibilityRestriction API documentation - Swagger

Keywords

backend, synch, VC, KB, Product, server , Fatal, error , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Bug Filed

Product

SAP CPQ 2025