SAP Knowledge Base Article - Public

3595863 - The Extensions Option is not Available for Contact Advanced Search

Symptom

You cannot see the "Extensions" option when trying to add a Custom Field for Contact Advanced Search.

Environment

  • SAP Sales Cloud Version 2
  • SAP Sales and Service Cloud Version 2

Reproducing the Issue

  1. Open the Navigation menu.
  2. Select Target Groups view.
  3. Click to create a new Target Group.
  4. Start the Adaptation mode.
  5. Click "Add Contact".
  6. Open the Advanced Search.
  7. Click edit > Add field.
  8. The option "Extensions" is not visible.

Cause

The Extensions option is not visible because there is no Custom Field "Filterable" and "Searchable" for the Contact Entity.

Resolution

In order to change the Custom Field Attributes, please follow the steps below:

  1. Select User Menu.
  2. Settings > All Settings.
  3. Open the Extensibility Administration.
  4. Search and Select the entity (e.g., Account or Contact).
  5. Go to the Field Attributes tab.
  6. Ensure that both the "Filterable" and "Searchable" Properties are checked for the Custom Field.
  7. Once these properties are enabled, you should be able to see the Extensions option and select the Custom Field in the Advanced Search.

See Also

KBA 3536683 - Extension Field Cannot Be Added to the Advanced Search

Keywords

Extensions, Advanced Search, Contact, Account, Custom Field, Sales Cloud Version 2 , KBA , CEC-CRM-CZM-EXT , Extensibility for SAP Sales/Service Cloud , CEC-CRM-CON , Contact for SAP Sales/Service Cloud , CEC-CRM-TGP , Target Group for SAP Sales/Service Cloud , CEC-CRM-ACC , Account for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0