Symptom
In the Kiwi Saver compliance form, when the question "Are you eligible for Kiwi Saver deduction?" is answered with "NO", an exemption reason is entered and the form is submitted, a message regarding the signature appears. However, when proceeding to the next step, the signature is not available.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Navigate to the Kiwi Saver compliance form.
- Answer "NO" to the question "Are you eligible for Kiwi Saver deduction?".
- Enter an Exemption Reason.
- Submit the form and note the message regarding the signature.
- Proceed to the next step and observe that the form is not present.
Cause
The system is designed to not generate any form for candidate signature when a candidate/New hire selects an Exemption from submitting Kiwi Saver form, as this form should not be submitted to Inland Revenue. However, a generic form is generated for employer/admin record by recording the exemption reason selected by the candidate. This behavior is verified by country experts/New Zealand product team.
Resolution
This is an expected behavior when a candidate/New hire selects an Exemption from submitting Kiwi Saver form.
Note that no form is generated for candidate signature in this scenario, but a generic form is generated for employer/admin record by recording the exemption reason selected by the candidate.
Access the generic form generated when a candidate selects the Exempt option via Onboarding document or through Manage documents page.
See Also
Refer to the Kiwi Saver guidelines at [Kiwi Saver Guidelines] for more information.
Keywords
SAP, SuccessFactors, Onboarding, Kiwi Saver Deduction Form, Exemption, Signature, Compliance Form, Expected Behavior, Employer Record, Admin Record, Generic Form. , KBA , LOD-SF-OBX-FRM , Compliance 2.0 Country Forms (except i9&EV) , Problem