Symptom
When invoice a Customer Invoice Request, split occurs into four new invoices. The expectation is to have only one invoice generated from the application.
Environment
SAP Business ByDesign
Reproducing the Issue
- Navigate to the Customer Invoicing work center.
- Open the Invoice Request.
- Search for the Invoice Request ABC.
- Click on the Invoice button.
- New invoice got split.
- Select the invoices and click on Split Invoice
- System shows split reason as below:
Invoice ID : #1 2024-12-13T08:00:00 UTC+8
Invoice ID : #2 2025-01-24T08:00:00 UTC+8
Invoice ID : #3 2025-01-10T08:00:00 UTC+8
Invoice ID : #4 2025-02-20T08:00:00 UTC+8
For the line items listed under Criteria, different values are in the Original Date.
Cause
Some line items in the Customer Invoice Request were processed when the Original Date was set to Date 1, while other line items were processed when the field was set to Date 2, Date 3, or Date 4.
The system maintains the original values for already processed line items while applying new values to newly processed line items, resulting in the invoice split.
Resolution
This is standard system behavior.
If there are open sales documents, the new value should update to newly processed line items. Already processed line items keep the old value.
If sales documents already released and it's not possible to change the field at sales order level. You need to cancel the outbound delivery and create a new sales order with the same date information maintained.
Keywords
Invoice Splitting, Original Date, Invoice Request, , KBA , SRD-CRM-INV , Customer Invoicing , Problem