Symptom
Post 1H 2025 release, the My Profile/Account page not working with new Candidate Experience. Once you try to open the page, the Candidate receives the following message: "Looks like something went wrong. Please try again or contact your administrator for help."
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors Recruiting Management
Cause
The cause is currently being investigated by SAP Software Engineering team.
Resolution
Currently, there are no available workarounds.
If you would like further updates on the progress, please follow up on this KBA by clicking on the star icon in the upper right corner. For more information about updates from subscribed KBAs, refer to the KBA: 2171560 - How to be notified of new or updated SAP Notes or KBAs - SAP ONE Support Launchpad.
See Also
Recruiting Implementation Guide - Reimagined Candidate Experience
Keywords
went, wrong, CX, new, candidate, exp, experience, error, my, profile, account, manage, KI2505, WEF-163854, CX2505 , KBA , LOD-SF-RCM-CAN-CX , Candidate eXperience redesigned , Known Error