SAP Knowledge Base Article - Public

3595993 - Long Internal Processing Time is observed in Performance Analysis tool when opening a story based on Live Datasphere data in SAP Analytics Cloud

Symptom

  • When opening a story based on Live Data Connection in SAP Analytics Cloud (SAC), the internal processing time for "open page" shown in Performance Analysis Tool is significantly long (4-10 seconds).
  • The issue is not related to a specific widget or the amount of data returned from the Data Warehouse Cloud (DWC).

Environment

  • SAP Analytics Cloud 2025.1
  • SAP Data Warehouse Cloud

Reproducing the Issue

  1. Log in to SAP Analytics Cloud
  2. Open one story which is based on Live Datasphere data.
  3. Go to Performance Analysis Tool and find the record for opening the story.
  4. Click to open detail and go to "Loading Sequence", find that the internal processing time is always taking at least 3-4 seconds which cannot be reduced. Sometimes this internal processing can be longer, e.g. longer than 10 seconds.

Cause

This is a product limitation in the above workflow.

Resolution

The long internal processing time is the process of authenticating user between SAP Analytics Cloud and SAP Datasphere. The end user cannot control such kind of internal processing time.

Keywords

SAP Analytics Cloud, Performance Analysis Tool, Internal Processing Time, Live Data Connection, Data Warehouse Cloud, Open Page, Reproduce, Issue, Error Message. , KBA , LOD-ANA-XUS , User assistance, performance statistics , Problem

Product

SAP Analytics Cloud 1.0